No flushes in token-api live sink on Polygon network
Resolved·Full outage

All Polygon live sinks are now fully operational and up to date. The firehose and all sink types—including Tokens, NFTs, Contracts, and Dexes—have resumed normal operation. Polygon data in the Token API is current, and downstream services should now receive up-to-date information.

Thu, Sep 11, 2025, 06:19 AM
(3 months ago)
·
Affected components
Updates

Resolved

All Polygon live sinks are now fully operational and up to date. The firehose and all sink types—including Tokens, NFTs, Contracts, and Dexes—have resumed normal operation. Polygon data in the Token API is current, and downstream services should now receive up-to-date information.

Thu, Sep 11, 2025, 06:19 AM

Monitoring

Problem: The live sink on the polygon network at riv-prod1 has not performed any flushes in the last 15 minutes. Impact: Latest data on the polygon network at riv-prod1 is not up-to-date. Causes: The polygon firehose is stuck, which is causing the polygon live sinks to fall behind. Steps to resolve: The team is working on fixing the stuck polygon firehose.

Thu, Sep 11, 2025, 06:15 AM

Monitoring

The Polygon firehose is now fully caught up and processing live blocks. All firehose nodes are in sync and operational. Contracts and Dexes live sinks are fully caught up. Tokens and NFTs live sinks are still catching up but are expected to be up-to-date shortly.

Thu, Sep 11, 2025, 05:11 AM(1 hour earlier)

Monitoring

The Polygon firehose is now fully caught up and processing live blocks. All firehose nodes are in sync and operational. Contracts and Dexes live sinks are fully caught up. Tokens and NFTs live sinks are still catching up but are expected to be up-to-date shortly.

Thu, Sep 11, 2025, 05:10 AM

Monitoring

The Polygon firehose is now fully caught up and processing live blocks. All firehose nodes are in sync and operational. Contracts and Dexes live sinks are fully caught up. Tokens and NFTs live sinks are still catching up but are expected to be up-to-date shortly.

Thu, Sep 11, 2025, 04:01 AM(1 hour earlier)

Monitoring

Problem: The live sink on the polygon network at riv-prod1 has not performed any flushes in the last 15 minutes. Impact: Latest data on the polygon network at riv-prod1 is not up-to-date. Causes: The polygon firehose is stuck, which is causing the polygon live sinks to fall behind. Steps to resolve: The team is working on fixing the stuck polygon firehose.

Thu, Sep 11, 2025, 03:56 AM

Identified

Polygon firehose is now processing live blocks. This will allow the Token API sync to catch up.

Thu, Sep 11, 2025, 03:46 AM(10 minutes earlier)

Identified

Problem: The live sink on the polygon network at riv-prod1 has not performed any flushes in the last 15 minutes. Impact: Latest data on the polygon network at riv-prod1 is not up-to-date. Causes: The polygon firehose is stuck, which is causing the polygon live sinks to fall behind. Steps to resolve: The team is working on fixing the stuck polygon firehose.

Wed, Sep 10, 2025, 11:15 PM(4 hours earlier)

Identified

The Token API sync is dependent on Firehose. Firehose update is still pending to process recent Polygon blocks.

Wed, Sep 10, 2025, 05:17 PM(5 hours earlier)

Identified

Problem: The live sink on the polygon network at riv-prod1 has not performed any flushes in the last 15 minutes. Impact: Latest data on the polygon network at riv-prod1 is not up-to-date. Causes: The polygon firehose is stuck, which is causing the polygon live sinks to fall behind. Steps to resolve: The team is working on fixing the stuck polygon firehose.

Wed, Sep 10, 2025, 03:41 PM(1 hour earlier)

Identified

Polygon network is having stability issues. This is impacting Polygon Firehose which in turn is impacting Polygon Token API. Work is going on to stabilise firehose and Token API will in turn be resolved. Next update within 1 hour.

Wed, Sep 10, 2025, 03:07 PM(33 minutes earlier)

Identified

The live NFTs sink on the matic network at riv-prod1 has not performed any flushes in the last 15 minutes.

Wed, Sep 10, 2025, 02:33 PM(34 minutes earlier)

Investigating

Wed, Sep 10, 2025, 02:26 PM