Arbitrum Sepolia Testnet - Firehose is having an issue
Resolved·Partial outage

Firehose has caught up.

Mon, Oct 13, 2025, 09:33 PM
(2 months ago)
·
Affected components
Updates

Resolved

Firehose has caught up.

Mon, Oct 13, 2025, 09:33 PM

Investigating

New blocks are no longer being processed.

Mon, Oct 13, 2025, 02:16 PM(7 hours earlier)

Investigating

We are investigating reports of degraded performance for Firehose

Mon, Oct 13, 2025, 01:15 PM(1 hour earlier)