Resolved
This incident has been resolved.
Identified
The chain is not finalizing blocks. Waiting for this to be resolved upstream.
Investigating
We are investigating reports of degraded performance for Firehose
·