No components marked as affected
Resolved
Blast Sepolia Testnet are now removed from our support
Resolved
This incident has been resolved.
Identified
Identified as chain issue. Waiting for Blast Team update
Investigating
This is a chain issue, and the chain has been stuck at block height 30579941
Investigating
We are investigating reports of degraded performance for Firehose