Resolved
The chain is moving forward again properly.
Investigating
The consensus layer blocks are not being finalized in a timely fashion. Last finalized block is 20490125.
Investigating
We are investigating reports of degraded performance for Firehose