Resolved
This incident has been resolved.
Monitoring
Our heimdall nodes are in sync now, archive node is syncing
Identified
Polygon is currently seeing a temporary network delay in block finality. Polygon team is actively investigating the cause and coordinating to restore full functionality.
Thank you for your patience!