Complete
BSC has been working well.
In progress
BSC is operating normally since the hard fork. Engineering is monitoring node stability.
In progress
Maintenance has started
Scheduled
BSC Mainnet Osaka/Mendel hard fork
The hard fork time is 2026-04-28 02:30:00 UTC
No downtime is expected.
Blockchain clients will be updated prior to the hard fork.