Pinax

Contact usSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Issue with RPC
Resolved·Degraded performance
Mon, May 11, 2026, 01:30 PM
(1 month ago)
·
Affected components
May 11, 2026, 01:29 PM
01:30 PM
Updates

Resolved

(not set)

Mon, May 11, 2026, 01:30 PM

Investigating

We are having an issue with RPC. Investigating it now.

Mon, May 11, 2026, 01:29 PM