Complete
Datacenter power maintenance has been completed.
In progress
Power maintenance is currently in progress and may be completed earlier than expected.
In progress
Maintenance has started
Scheduled
Preventative Maintenance Window - June 6th, at 8am EDT until 6pm EDT
Electrical systems maintenance is planned at one of the Pinax datacenters.
Maintenance will be performed on backup generators. No power disruptions are expected, but redundancy will be degraded during the maintenance window.