We are having an issue with RPC on eth. Fixing it now.
Fri, May 29, 2026, 04:05 AM(16 minutes earlier)
Investigating
There are fewer Ethereum Mainnet nodes online than usual, so performance may be impacted. Work is ongoing to restore the full complement of archive nodes.
Fri, May 29, 2026, 03:34 AM(30 minutes earlier)
Investigating
We are having an issue with RPC on eth. Investigating it now.
Fri, May 29, 2026, 03:26 AM
RPC Degraded Performance on Ethereum Mainnet - Pinax Status