Resolved
The issue is now fixed.
Investigating
Balances are consistently delayed by more than 10 minutes. Team continues investigating the infrastructure changes that needed to bring the balances latency back to live.
Investigating
We are now Investigating the incident