Resolved
The underlying storage performance issue has been resolved.
Investigating
There are intermittent delays creating firehose merged blocks, block index and substreams state due to underlying storage maintenance process that is taking more compute resources than usual.