Pinax

Contact usSubscribe to updates
Powered by
Privacy policy

·

Terms of service
RPC Degraded Performance on OP Sepolia Testnet
Resolved·Degraded performance
Wed, Jun 17, 2026, 07:01 PM
(1 week ago)
·
Affected components
Jun 17, 2026, 06:49 PM
07:01 PM
Updates

Resolved

(not set)

Wed, Jun 17, 2026, 07:01 PM

Investigating

We are investigating reports of performance issues for OP Sepolia Testnet in the RPC service.

Wed, Jun 17, 2026, 06:49 PM(11 minutes earlier)