Resolved
Not an issue.
Identified
We have identified the problem causing performance issues for Avalanche C-Chain in the RPC service and are working to resolve it.
Resolved
RPC service on Avalanche C-Chain is fully operational
Investigating
We are investigating reports of performance issues for Avalanche C-Chain in the RPC service.