·
Resolved
(not set)
Identified
We have identified the problem causing performance issues for BNB Smart Chain Chapel Testnet in the RPC service and are working to resolve it.
Investigating
We are having an issue with RPC on chapel. Paused it now.